Windows: MergeIDE ist nicht gleich MergeIDE!

Interessante kleine Erfahrung beim Ausrollen eines Windows XP Professional-Abbilds:

  • Master-PC in VirtualBox vorbereitet, d.h. Windows mit allen aktuellen Updates installiert, temporären Benutzer samt Profil gelöscht.
  • Sysprep mit der Option „reseal“ ausgeführt.
  • Abbild mit Drive Snapshot erstellt.

Soweit alles ok.

  • Abbild auf einem PC aufgespielt.
  • Neustart.
  • Bluescreen 0x0000007b.

Das war zu erwarten, da die Hardware unterschiedlich ist.

  • PC von Rettungs-CD gestartet.
  • Drive Snapshot mit der Option „–mergeide“ ausgeführt.
  • Neustart.
  • Wieder Bluescreen 0x0000007b.

Seltsam. Nächster Versuch:

  • PC von Rettungs-CD gestartet.
  • MergeIDE aus dem Netzwerk auf den PC kopiert und ausgeführt.
  • Neustart.
  • Läuft.

Allem Anschein nach fehlt entweder ein Registrierungseintrag oder ein Treiber bei MergeIDE von Drive Snapshot. Das es Unterschiede zwischen MergeIDE in Abhängigkeit von der Windows-Version gibt, ist bekannt. So muss ab Windows Vista und neuer wohl kein Treiber mehr entpackt werden.

Anmerkung: Es handelt sich in diesem Fall um gebrauchte Pentium 4 HT-PCs, also nicht Stand der Technik und damit auch kein SATA.

Update 12.08.2012

Anscheinend gibt es noch mehr Differenzen. Ohne nun Drive Snapshot etwas negatives nachsagen zu wollen, aber bei einer Migration von Windows 7 Professional x64 von physikalischer Hardware zu VirtualBox reichte MergeIDE von Drive Snapshot nicht aus. Meine Variante von MergeIDE für Windows Vista und neuer löste das Problem.

4 Kommentare

  • Pingback: Windows: Rettungs-CD für Drive Snapshot v2.0 | Andys Blog – Linux, Mac, Windows

  • Heinrich Pechtold

    Vielen Dank dafür!
    Ich ziehe gerade eine Server 2003 auf ProxmoxVE um, weil noch wichtige Daten auf dem alten Server sind, die gesichert / umgezogen werden müssen. Somit ist die Arbeit temporär, aber Installation der VirtIO scsi Treiber vor dem Clonen hat leider nichts gebracht. Es gibt nicht einmal einen Bluescreen, sondern ein Cursor blinkt einsam oben links. Somit probiere ich nun mergeIDE aus, um das Ziel nach dem Clonen (Sektorkopie mit ddrescue) dann in einer IDE Umgebung zu booten.
    Das sieht sehr hoffnungsvoll aus.

  • Hallo Heinrich,

    sollte eigentlich lösbar sein. Ich lege dir die aktuelle MergeIDE-Version von mir Nahe:

    Windows: MergeIDE v3.0

    Blackscreen mit Cursor kann leider ein paar Ursachen haben, wie z.B. „zerschossene“ Boot-Umgebung, unpassende HDD-IDs (gerade bei Backup/Restore und Klonen ein Problem), usw.
    Mal über die Setup-CD/-ISO mit „bootrec /fixboot“ usw. ein Rep.-Versuch wagen.

    Ansonsten mal mit anderen Tools (Drive Snapshot, Macrium Reflect, …) die Migration testen.
    Da gibt es durchaus große Unterschiede, vor allem bei Restore was (automatisch) angepasst wird, damit es wieder läuft.

  • Noch eins: Erstmal auf IDE statt dirket auf VirtIO migrieren. Das ist erstmal einfacher und kann i.d.R. später noch geändert werden.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.