ArchivistaVM: Sprache automatisch einstellen

Beim Starten von ArchivistaVM erscheint immer eine Abfrage nach der Sprache, ganz gleich ob man zuvor das System schon mal auf dem Computer laufen hatte oder nicht.

Per Standard werden alle Einstellungen (IP-Adresse, Hostname, virtuelle Maschinen, Sprache der Oberfläche) beim Beenden gespeichert.

Das eigentliche Problem im weitesten Sinne besteht nicht unbedingt in der Auswahl der Sprache, sondern darin, das ohne eine bestätigte Auswahl der Startvorgang nicht fortgeführt wird.

Um diesen Umstand zu umgehen, muss lediglich eine kleine Anpassung vorgenommen werden.

Kommt ein USB-Stick als Boot-Medium zum Einsatz, so muss man die Datei „syslinux.cfg“ editieren. Dies kann direkt auf dem Stick erfolgen. Wird ein ISO-Abbild bzw. eine daraus erstellte CD verwendet, so muss man die Datei „isolinux.cfg“ bearbeiten und das Abbild und ggf. die CD neu erstellen. Eine Anleitung, wie man das ISO-Abbild anpassen kann, findet sich hier.

Die Syntax der Änderung ist in beiden Fällen identisch. Per Standard wird, sofern keine andere Auswahl getroffen wird, die Konfiguration aus dem Abschnitt „ram“ übernommen.

An der Zeile, die mit „APPEND“ beginnt muss lediglich

keyboard.de_DE lang.de auto

angefügt werden.

Ein Kommentar

  • Das ist richtig, die Idee dahinter, dass es nicht 100% automatisch hochfährt ist die, dass wir sonst praktisch nicht mehr in den Debug-Modus kommen würden (bzw. wir müssten dann die Wartezeit auf dem ersten Screen viel länger setzen — und das möchten wir eben auch nicht). Vielleicht findet sich ja dereinst ein eleganterer Weg…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.