VirtualBox, EFI und Abstürze

Angefixt vom Artikel UEFI für VMs in VirtualBox aktivieren wollte ich gerade einmal eine Installation von Windows 8 Release Preview x64 mit EFI unter VirtualBox testen. Allerdings kam direkt nach dem Starten der virtuellen Maschine die Meldung, das VirtualBox nicht mehr reagiert.

Seltsam, hatte doch EFI und VirtualBox in der Vergangenheit bislang funktioniert, zumindest in Verbindung mit Mac OS X. Nach kurzem googeln war die Sache zunächst geklärt. Das Problem hängt irgendwie an den 128 MB Grafikspeicher. Verringert oder erhöht man Diesen, ich habe sowohl mit 64 als auch 256 MB getestet, so startet die virtuelle Maschine ohne Probleme. Es scheint allerdings, als ob sich dieses Problem am stabilsten mit 64 MB lösen lässt. Andere Einstellungen haben im Test nur ein bis zwei Mal funktioniert. Das Problem ist nicht neu, wie man hier sieht. Allerdings tritt dieses Problem wohl auch nicht auf jedem Computer auf. So stürzte VirtualBox zwar auf meinem Notebook immer wieder ab, aber auf dem Desktop läuft es mit 128 MB Grafikspeicher.

Leider war auf beiden Computern keine Installation von Windows 8 Release Preview x64 mit EFI unter VirtualBox möglich. Letztlich dümpelte VirtualBox mit 50% CPU-Auslastung vor sich hin und es wurde lediglich „Windows“ in der virtuellen Maschine nach dem booten bzw. beim booten vom ISO-Abbild angezeigt. Schade.

So bleibt abschließend die Frage erstmal offen, ob nun VirtualBox bzw. die dortige EFI-Implementierung oder Windows 8 Release Preview den oder die Fehler verursachen.

Meine Umgebung:

  • Windows 7 Professional x64 Host
  • VirtualBox 4.1.16

Ein Kommentar

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.