3CX: Telekom-SIP-Trunks registrieren sich nicht mehr

Kurz zur Info für alle 3CX-Admins denen ebenfalls dieses Problem in Verbindung mit der Deutschen Telekom begegnen kann: Wenn plötzlich die SIP-Trunks sich nicht mehr registrieren, d.h. die Anmeldung fehlschlägt, kann die Abhilfe darin bestehen, das Transport-Protokoll zu ändern.

Im jeweiligen SIP-Trunk unter “Optionen – Erweitert” bei “Transportprotokoll” dieses von “TCP” zu “Alle” oder “UDP” ändern:

Unfreiwillig erfolgreich getestet unter 3CX V18 Update 5 an einem Telekom All IP-Anschluss. Vermutlich hängt diese Sache mit der Plattform-Umstellung der Telekom zusammen, da sind auch schon andere Anlagen “rausgeflogen”.

Wichtig: Ggf. Firewall-Regeln im Router für das geänderte Transportprotokoll anpassen!

Quelle

3CX Forum – Telekom ALL IP Anschluss registriert nicht mehr

Update 28.09.2022

Vielen Dank für die Kommentare. Man kann Alternativ das Transportprotokoll auch auf “UDP” stellen, entsprechend wurde der Beitrag aktualisiert.

Bei einem Kunden half zwar sowohl “Alle” als auch “UDP” damit sich die SIP-Trunks wieder registrieren können, aber leider gibt (oder hoffentlich nun gab) es jede Menge weiterer Probleme.

Diese äußern sich in folgenden Formen:

  • Man kann nicht angerufen werden, es gibt allerdings keine Fehlermeldung bzw. Fehleransage. Der Anrufversuch wird zudem nicht in der Anrufliste aufgeführt.
  • Es kommt eine Telekom-Ansage, das die Rufnummer nicht erreichbar wäre, obwohl der SIP-Trunk erfolgreich registriert ist und Sprachkanäle frei sind.

Ich konnte den Kunden nun ebenfalls reproduzierbar mehrfach nicht erreichen, meine Anrufversuche tauchten gar nicht erst in der Anrufliste der 3CX auf. Auf der beim Kunden vorhandenen Securepoint UTM das Ganze mit tcpdump beobachtet und dabei festgestellt, das der Anruf(versuch) auf jeden Fall ankommt, aber nicht beantwortet werden kann.

Daraufhin folgende Einstellungen geändert:

Update 27.10.2022

Die Änderungen vom vorigen Update habe ich wieder zurückgenommen und stattdessen das Regelwerk der Firewall, in diesem Fall Securepoint UTM, überarbeitet. Die vorigen Regeln basierten auf den Erkenntnissen aus diesem Fall bzw. Beitrag:

Securepoint UTM: Telekom-VoIP-Gespräche brechen nach 15 Minuten ab

Das funktionierte so jahrelang ohne Probleme bis zu dem Zeitpunkt, als die Telekom offenbar irgendetwas an der Plattform geändert hat. Die neuen Regeln basieren auf folgende Wiki-Seite des Firewall-Herstellers:

Securepoint – Wiki – UTM zwischen VoIP-Client und VoIP-Server

Im Screenshot zu sehen sind oben die deaktivierten alten, sowie die neuen aktiven Regeln:

Statt global Internet könnte man versuchen das Ganze auf Telekom-Server einzugrenzen. Da es hierzu allerdings keine Liste gibt, dürfte die Einschränkung einen gewissen administrativen Aufwand inkl. ständigen nachpflegen bedeuten.

Die Änderungen wurden bereits vor über zwei Wochen vorgenommen und seitdem gab es keine Probleme mehr.

8 Kommentare

  • Vielen Dank!

    Der Tipp hat bei uns und betroffenen Kunden geholfen.

    Heiko Höhne / diversys.IT

  • Wir haben es gestern bei einem Kunden gehabt und dort auf UDP gestellt. Seitdem funktionierts ebenfalls.

  • Danke dir!

    Suche schon seit 2 Wochen daheim an meiner Anlage.

  • Hallo Timo,

    stimmt, UDP geht auch.
    Ich hab bei einem Kunden allerdings noch weitere Probleme, siehe das Blog-Update von heute.

    Mal so als Frage in die Runde: Habt ihr auch sowas oder andere Schwierigkeiten?

  • Hi Andy,

    genau das Thema habe ich aktuell auch gehabt. Bei der Einstellung auf 60 Sekunden brechen die Telefonate aber regelmäßig während des Gespräches an. Daher habe ich es nun auf 1800 gestellt. Damit brechen die Anrufe nun nicht mehr ab.
    Nun läuft es vollkommen sporadisch. Erreichbar scheint der Kunden nun durchgängig zu sein. Ausgehende Anrufe werden aber manchmal mit “forbidden” protokolliert. Teilweise gehen diese aber auch durch.

    Es wurde nun ein Ticket bei der Telekom aufgemacht. Vermutlich werden diese sich dem Thema nicht wirklich annehmen. Aber die Hoffnung stirbt zuletzt.

    Wenn du noch Ideen hast, gerne her damit.

  • Unsere Kunden nutzen zwar kein Telekom sondern Peoplefone, doch seit ca. 1 Woche sind eingehende Anrufe aus dem Telekom Netz nicht mehr möglich.

    Wie im Blog geschrieben passiert genau das hier:

    Man kann nicht angerufen werden, es gibt allerdings keine Fehlermeldung bzw. Fehleransage. Der Anrufversuch wird zudem nicht in der Anrufliste aufgeführt

    Wartet man aber 30 bis 60 Sekunden Stille ab, fängt es ab und zu doch noch an zuwählen.

  • Hallo zusammen,

    habt ihr das Problem “Man kann nicht angerufen werden, es gibt allerdings keine Fehlermeldung bzw. Fehleransage. Der Anrufversuch wird zudem nicht in der Anrufliste aufgeführt.” noch?
    Ich bekomme es nicht weg.
    Ich kann raus telefonieren, es klingelt auch aber es kommt kein Gespräch zustande.
    Angerufen werden kann ich gar nicht.

    Grüße Matze

  • D.h. es fehlt nur Audio?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert