Microsoft Surface (Pro) im WLAN langsam

Es gibt ein paar potentielle Lösungswege die Handbremse bei der WLAN-Nutzung von Microsoft Surface Tablets und Books zu lösen.

Vor allem seit dem Surface Pro 3 bekommt man immer wieder von schlechter WLAN-Performance etwas zu hören bzw. zu lesen. Hintergrund war und ist scheinbar, das es mit den (je nach Surface-Modell) verbautem Marvell AVASTAR Wireless-AC-Chip bzw. dessen Treibern Schwierigkeiten gibt.

Microsoft hatte zuletzt Anfang 2020 speziell zu diesem Problem Treiber-Updates veröffentlicht, in der Zwischenzeit gab es mindestens ein weiteres Update.

Bei manchen Nutzern traten Probleme zudem erst nach Windows 10-Upgrades, z.B. von 1909 auf 2004, auf. Zusätzlich kompliziert ist das Thema aufgrund der Tatsache das es nicht generell, sondern wohl nur mit verschiedenen WLAN-Routern bzw. -Access Points auftritt. Alles in allem eine lästige Angelegenheit.

Persönlich habe ich dieses Drama erst jetzt mit einem Surface Pro von 2018 im Zusammenhang mit einem Ubiquiti Unifi UAP-AC-Pro erlebt. Grundsätzlich kam eine Verbindung zu stande, die Performance z.B. beim Kopieren von Dateien war mit 2 -5 MBit/s gelinde ausgedrückt verbesserungswürdig, alle anderen WLAN-Geräte hingegen funktionieren wie erwartet.

Nach etwas Recherche fanden sich der Reihe nach folgende work-arounds:

In der Registry im Schlüssel

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\mrvlpcie8897

den Wert von „TxAMSDU“ von „1“ auf „0“ ändern und das Gerät neu starten. Bei manchen soll das Helfen, in diesem Fall leider nicht. Die Einstellung wurde allerdings so belassen.

Offenbar hängen die Probleme je nach Modell mit Bluetooth zusammen, von daher sollte man dieses wenn möglich deaktivieren. Das half hier zwar auch nicht, dennoch wurde es mal abgeschaltet gelassen.

Zu guterletzt kann man in den Treiber-Einstellungen des Marvell-Chips das zu nutzunde Frequenzband festlegen, ab Werk steht hier „Auto“. Theoretisch soll so von selbst entschieden werden ob 2.4 oder 5 GHz verwendet wird, je nachdem welches gerade besser ist. Offenbar funktioniert aber gerade das nicht zufriedenstellend. Ein erster Versuch nur mit 2.4 GHz zeigte nach wie vor große Probleme, in der Gegenrichtung, sprich 5 GHz, war dann plötzlich Schluß mit Langsam und so läuft es seitdem.

Ideal ist dieser work-around allerdings nicht wenn das Gerät viel außerhalb des (Firmen-)Netzes verwendet wird, ggf. kommt so keine Verbindung z.B. zum Smarthone-Hotspot oder anderen mitunter 2.4 GHz only Netze mehr zustande.

Update 26.10.2020

Folgende Versuche in Verbindung mit dem Ubiquiti Unifi-Equipment haben leider nicht geholfen:

Das Aktivieren von

Geräte mit hoher Performance (Beta): Endgeräte mit hoher Performance werden ausschliesslich mit 5 GHz verbunden

hilft zwar anderen Geräte ins schnellere 5 GHz Netz zu wechseln, allerdings wird dies vom genannten Surface quasi ignoriert.

Das Aktivieren von Band Steering soll ebenso dazu beitragen, das Geräte die beides (2.4 und 5 GHz) können, in das optimale Netz gelangen. Dieses muss zunächst für die Site aktiviert werden:

Einstellungen - Site/Standort - Erweiterte Funkionen - Erweiterte Funktionen aktivieren

Anschließend wird die Funktion unter

Geräte - <Access Point> - Konfiguration - Band Steering

eingestellt. Ab Werk ist „Ausbalanciert“ vorgegeben, dieses kann z.B. auf „5 GHz bevorzugen“ gesetzt werden.

Aber auch das bringt mit dem Surface leider nichts.

Quelle: Noveres.com – Prefer 5GHz on Ubiquiti UniFi AP’s by using Band Steering

Als mittlerweile „Plan D“ wurde dann ein neues Netz eingerichtet, das nur „5 GHz“ ist und das Surface dorthin verbunden. Zuvor wurde im Treiber die „5 GHz only“-Einstellung wieder zurückgenommen.

Und so läuft es im Moment. Auch wenn es etwas mehr Aufwand ist, so entfällt die Einstellung am Surface selbst, mit der man riskiert dass das Gerät außerhalb des eigenen WLANs sich nicht verbinden kann, wenn bspwl. kein 5 GHz zur Verfügung steht.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.