Shrew Soft: Verbindung wird erfolgreich aufgebaut, aber es gehen keine Daten durch

Wird die Verbindung mittels Shrew Soft VPN-Client erfolgreich aufgebaut, aber es gehen keine Daten durch, so kann dies einen simplen Grund haben.

Sofern Routing- und Firewall-Konfiguration stimmen und richtig gesetzt wurden und die Verbindung in der Vergangenheit bereits erfolgreich funktionierte, liegt dieser „Aussetzer“ vermutlich an einem abgstürzten oder anderweitig gestörten Dienst.

Unter Windows können der Status und ein (Neu-)Start der notwendigen Dienste in der entsprechenden MMC überprüft und durchgeführt werden:

  • ShrewSoft IKE Daemon (Dienstname: iked)
  • ShrewSoft IPSEC Daemon (Dienstname: ipsecd)

Bei einem Supportfall war der Dienst „ShrewSoft IPSEC Daemon“ beendet. Nachdem dieser und der erstgenannte (neu)gestartet und die VPN-Verbindung nochmals neu aufgebaut wurde, klappte wieder alles wie gewohnt.

4 Kommentare

  • *** Shrew Client hinter Digitalisierungsbox ***
    Ich habe folgende Erfahrung gemacht: VPN-Verbindungen mit dem Shrew-Client funktionieren zu einer Fritz-Box, Digitalisierungsbox (Telekom), Lancon-Router,
    wenn sich der PC mit dem Shrew-Client hinter einem Router Fritz-Box, Lancon-Router, Zyxel-Router, Handy (Tethering) befindet.
    Versuche ich, durch mit dem Shrew-Client eine Verbindung durch eine Digitalisierungsbox hindurch aufzubauen, wird die Verbindung hergestellt, aber keine Daten durch den Tunnel transportiert. Ich habe es hinter drei verschiedenen Digitalisierungsbox (drei Firmen) zu verschiedenen Zielen versucht, immer erfolglos.
    Erst mit dem kostenpflichtigen elmeg-bintec-VPN-Client hat es funktioniert, ohne dass ich in den Digitalisierungsboxen noch irgendetwas ändern musste.
    Die Digitalisierungsbox ist ein elmeg-bintec-Produkt. Ich enthalte mich jeder Vermutung…
    Hat jemand das gleiche Problem? Gibt eine Lösung für eine VPN-Verbindung durch eine Digitalisierungsbox mit dem Shrew-Client?
    Viele Grüße, Thoralf

  • Ich hatte mal Schwierigkeiten in Verbindung mit einer pfSense:

    VPN-Verbindung mit Shrew Soft VPN Client über eine pfSense zu einer AVM FRITZ!Box 7490 nicht erfolgreich

    Ob die Digiboxen sowas ähnliches machen weiß ich leider nicht. Die zwei die wir noch bei Kunden haben werden demnächst abgelöst.

  • @Thoralf
    ich habe aktuell genau die selben Erfahrungen gemacht. Vor einem Jahr ging die Verbindung mit der Digibox Prem. und Shrew VPN noch problemlos, mit dem neuen Update (und der viel schlimmeren Menuführung) geht jetzt nichts mehr.
    „Tunnle enabled“ aber keine Verbindung, jeder Ping geht in die Zeitüberschreitung. Bei mir funktioniert es nicht mal mehr mit dem Bintec VPN Client, trotz Export der Einstellungen.
    Ein sehr schlechtes Update. Wir überlegen auf die FritzBox 7583 zu wechseln, diese bieten auch zwei s0 ISDN Ports und ist natürlich ein Traum in der usability im Gegensatz zu diesem Bintec/Telekom Mist…

  • Wir hatten nur zwei Kunden mit einer DigiBox Prem., da eine hat neulich zu einer FritzBox und einer 3CX TKA gewechselt, der andere wird wohl auf die gleiche Kombi gehen. Einer der beiden hatte sogar seitens der Telekom eine (Ab)Kündigung der DigiBox erhalten, „Deadline“ war glaub‘ ich Ende März. In Sachen Handling ist fast alles was ich bisher in all den Jahren erlebt habe einfacher als DigiBox/bintec-elmeg oder LANCOM. Wenn’s ein richtiger VPN-Firewall-Router sein soll dann gerne eine pfSense oder OPNsense, wenn’s in Sachen Sicherheit mehr können soll dann beispielsweise eine Securepoint UTM. Von der VPN-Performance her ist die FritzBox nun nicht gerade der Renner und der ShrewSoft-Client wird offenbar seit Jahren nicht mehr weiterentwickelt. Der VPN-Client von AVM ist ähm naja.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.