Shrew Soft: Verbindung wird erfolgreich aufgebaut, aber es gehen keine Daten durch

Wird die Verbindung mittels Shrew Soft VPN-Client erfolgreich aufgebaut, aber es gehen keine Daten durch, so kann dies einen simplen Grund haben.

Sofern Routing- und Firewall-Konfiguration stimmen und richtig gesetzt wurden und die Verbindung in der Vergangenheit bereits erfolgreich funktionierte, liegt dieser “Aussetzer” vermutlich an einem abgstürzten oder anderweitig gestörten Dienst.

Unter Windows können der Status und ein (Neu-)Start der notwendigen Dienste in der entsprechenden MMC überprüft und durchgeführt werden:

  • ShrewSoft IKE Daemon (Dienstname: iked)
  • ShrewSoft IPSEC Daemon (Dienstname: ipsecd)

Bei einem Supportfall war der Dienst “ShrewSoft IPSEC Daemon” beendet. Nachdem dieser und der erstgenannte (neu)gestartet und die VPN-Verbindung nochmals neu aufgebaut wurde, klappte wieder alles wie gewohnt.

Update 25.03.2021

Liegt es nicht an den Diensten, so kann es weitere Kandidaten für diese Schwierigkeiten geben. Speziell unter Windows 10 sollte man prüfen, ob im Geräte-Manager unter “Netzwerkadapter” mindestens ein “Shrew Soft Virtual Adapter” vorhanden ist. Nicht wundern, wenn dieser nicht verwendet wird, ist der Adapter deaktiviert, das hat so seine Richtigkeit. Fehlt dieser Adapter, muss es manuell über “Aktion – Legacyhardware hinzufügen” installiert werden.

Speziell in Verbindung mit der AVM Fritz!Box muss es gar nicht am VPN-Client liegen. Die grundlegende Einrichtung ist hier beschrieben:

AVM – VPN Service-Portal – VPN-Verbindung zur FRITZ!Box mit Shrew Soft VPN Client einrichten

Wird der Tunnel erfolgreich aufgebaut und es funktioniert kein Routing, dann einmal die Fritz!Box neu starten. Danach sollte es dann laufen.

11 Kommentare

  • *** Shrew Client hinter Digitalisierungsbox ***
    Ich habe folgende Erfahrung gemacht: VPN-Verbindungen mit dem Shrew-Client funktionieren zu einer Fritz-Box, Digitalisierungsbox (Telekom), Lancon-Router,
    wenn sich der PC mit dem Shrew-Client hinter einem Router Fritz-Box, Lancon-Router, Zyxel-Router, Handy (Tethering) befindet.
    Versuche ich, durch mit dem Shrew-Client eine Verbindung durch eine Digitalisierungsbox hindurch aufzubauen, wird die Verbindung hergestellt, aber keine Daten durch den Tunnel transportiert. Ich habe es hinter drei verschiedenen Digitalisierungsbox (drei Firmen) zu verschiedenen Zielen versucht, immer erfolglos.
    Erst mit dem kostenpflichtigen elmeg-bintec-VPN-Client hat es funktioniert, ohne dass ich in den Digitalisierungsboxen noch irgendetwas ändern musste.
    Die Digitalisierungsbox ist ein elmeg-bintec-Produkt. Ich enthalte mich jeder Vermutung…
    Hat jemand das gleiche Problem? Gibt eine Lösung für eine VPN-Verbindung durch eine Digitalisierungsbox mit dem Shrew-Client?
    Viele Grüße, Thoralf

  • Ich hatte mal Schwierigkeiten in Verbindung mit einer pfSense:

    VPN-Verbindung mit Shrew Soft VPN Client über eine pfSense zu einer AVM FRITZ!Box 7490 nicht erfolgreich

    Ob die Digiboxen sowas ähnliches machen weiß ich leider nicht. Die zwei die wir noch bei Kunden haben werden demnächst abgelöst.

  • @Thoralf
    ich habe aktuell genau die selben Erfahrungen gemacht. Vor einem Jahr ging die Verbindung mit der Digibox Prem. und Shrew VPN noch problemlos, mit dem neuen Update (und der viel schlimmeren Menuführung) geht jetzt nichts mehr.
    “Tunnle enabled” aber keine Verbindung, jeder Ping geht in die Zeitüberschreitung. Bei mir funktioniert es nicht mal mehr mit dem Bintec VPN Client, trotz Export der Einstellungen.
    Ein sehr schlechtes Update. Wir überlegen auf die FritzBox 7583 zu wechseln, diese bieten auch zwei s0 ISDN Ports und ist natürlich ein Traum in der usability im Gegensatz zu diesem Bintec/Telekom Mist…

  • Wir hatten nur zwei Kunden mit einer DigiBox Prem., da eine hat neulich zu einer FritzBox und einer 3CX TKA gewechselt, der andere wird wohl auf die gleiche Kombi gehen. Einer der beiden hatte sogar seitens der Telekom eine (Ab)Kündigung der DigiBox erhalten, “Deadline” war glaub’ ich Ende März. In Sachen Handling ist fast alles was ich bisher in all den Jahren erlebt habe einfacher als DigiBox/bintec-elmeg oder LANCOM. Wenn’s ein richtiger VPN-Firewall-Router sein soll dann gerne eine pfSense oder OPNsense, wenn’s in Sachen Sicherheit mehr können soll dann beispielsweise eine Securepoint UTM. Von der VPN-Performance her ist die FritzBox nun nicht gerade der Renner und der ShrewSoft-Client wird offenbar seit Jahren nicht mehr weiterentwickelt. Der VPN-Client von AVM ist ähm naja.

  • Hallo!
    Bitte um Hilfe, wobei ich zugegebenermaßen ein relativer Anfänger bezüglich VPN bin. Mein Ziel ist es per VPN auf ein Fritz!NAS zuzugreifen. Über die Funktionen von AVM habe ich das leider nicht geschafft. Nun habe ich den Shrew VNO Client installiert und die VNP steht erfolgreich (Established: 1, Expired: 0, Failed: 0, Status: Connected). Wie schaffe ich es aber nun, über die VNP auf das Fritz!NAS und die Daten dort zuzugreifen? Am schönsten wäre es, wenn ich das NAS bei mir als Netzwerklaufwerk einbinden kann!
    Danke schon vorab für jede Hilfe!
    LG Peter

  • Hallo Andy,

    konntest du schon Erfahrungen mit dem ShrewSoft Client unter Windows 11 sammeln?

    Unter Windows 10 lief dieser bei mir jahrelang sehr stabil.

    Nun bin ich zum Test auf Windows 11 gewechselt.

    Installiere ich den Client, wird die Netzwerkverbindung sofort auf „nicht identifiziertes Netzwerk“ geändert. Ich erhalte vom Router keine IP mehr via DHCP.

    Deinstalliere ich den ShrewSoft Client wieder, funktioniert sofort alles.

    Für eine Antwort wäre ich dir sehr dankbar.

    Viele liebe Grüße.

    Arne

  • Hallo Arne,

    wirkliche Erfahrungen noch nicht. Hab’ es gerade mal auf die Schnelle in meiner Test-Umgebung ausprobiert und das lief der Client auf Anhieb und ohne Probleme.
    Handelt es sich bei dir um eine Upgrade-Installation von Windows 10 auf 11 oder wurde Windows 11 komplett neu installiert?
    In meiner Test-Umgebung handelt es sich um eine komplett neu saubere Installation. Evtl. macht das ja schon etwas aus.

    Nicht unerwähnt bleiben muss allerdings, das der Shrew Soft Client schon sehr alt ist, immerhin ist die “aktuelle” Version von 2013. Unter Windows 10 habe ich da immer wieder kleinere Schwierigkeiten gehabt, ich nutze den allerdings nur für die Kunden, wo es nur eine FRITZ!Box gibt, das sind nur eine Hand voll.

  • Hallo Andy,

    zuerst möchte ich dir für die wirklich schnelle und erstklassige Hilfe danken! Das weiß ich sehr zu schätzen!

    Also der PC ist komplett frisch mit Windows 11 installiert (kein Update von WIndows 10).
    Vorher lief das System jahrelang aber mit Windows 10, dabei gab es keine Probleme.
    Das System wurde über LAN betrieben, genau so betreibe ich es mit Windows 11 nun auch.

    Das System hat allerdings noch eine WLAN-Karte, ich werde mal versuchen ob ich hier eine VPN-Verbindung bekomme. Ist dies der Fall, muss es irgendetwas mit den Treiber der LAN-Karte bzw. der Windows-Config zu tun haben.

    Nun habe ich ein Notebook ebenfalls mit Windows 11 installiert, hier läuft der ShrewSoft Client perfekt. Verbindung wird allerdings über WLAN aufgebaut.

    Viele liebe Grüße und ein angenehmes Wochenende.
    Arne

  • Hallo Andy,

    so das Problem scheint gelöst.

    Lösung:
    Ich habe die Netzwerkkarten-Treiber vom Hersteller genommen und nicht die von Windows. Damit bleibt die Netzwerkverbindung bestehen und ich mich wieder via VPN ohne Probleme mit der FritzBox stabil verbinden.

    Vielen Dank nochmal für deine Hilfe und dir ein erholsames Wochenende.
    Arne

  • Hi Arne,

    vielen Dank für die Rückmeldung. Gut zu Wissen das es läuft und nur am Netzwerkkartentreiber gelegen hat.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.