Linux Mint 19.3: OpenVPN „killt“ alle Netzwerkverbindungen

Auf dem Homeoffice-Computer eines Kunden sollte nach dem Lebensende von Windows 7 nun Linux Mint zum Einsatz kommen.

Der Kunde hat bereits mehrere ältere Geräte auf diese Weise einem neuen oder gar dem gleichen Verwendungszweck wieder zugeführt. Meist geht es nur um Internetsurfen, Mails checken oder per VPN und RDP arbeiten.

Für letzteres kommt OpenVPN zum Einsatz. Eine aus einer pfsense exportierten Konfiguration wurde im Network Manager importiert, soweit, sogut. Eine Verbindung wird auch aufgebaut, aber dann geht weder Internet noch irgendein Paket durch den VPN-Tunnel.

Dieses (Fehl-)Verhalten scheint auf Ubuntu und in Folge Linux Mint bei der Verwendung des Network Managers und ggf. systemd beschränkt zu sein. Genaueres lies sich auf die Schnelle, wobei das schon ein paar Stunden waren, nicht ausfindig machen.

Interessanterweise gibt es keinerlei Schwierigkeiten wenn man im Terminal mit root-Rechten

openvpn <Konfigurationsdatei>

ausführt.

Einen Teilerfolg bzw. workaround erhält man, wenn man statt dem Import der OpenVPN-Konfiguration diese manuell anlegt. Dann funktioniert zwar nach dem Verbindungsaufbau immer noch kein Internet (mehr), aber dafür funktioniert die VPN-Verbindung so wie sie soll.

Randbemerkung und der Vollständigkeit halber: Durch das Kunden-VPN wird kein Internetverkehr geschickt, dieses dient lediglich dazu Zugriff auf einen Terminalserver zu bekommen.

Update 23.01.2020

So, wieder ein Stück weiter. Sieht man sich die Routen die nach dem OpenVPN-Verbindungsaufbau gesetzt sind an fällt schnell auf, dass das Standard-Gateway bzw. die Default-Route auf das OpenVPN-tun-Interface gesetzt ist:

Ziel Router Genmask Flags Metric Ref Use Iface
default _gateway 0.0.0.0 UG 50 0 0 tun0
default firewall.test.l 0.0.0.0 UG 100 0 0 enp3s0
10.0.8.0 0.0.0.0 255.255.255.0 U 50 0 0 tun0
192.168.0.0 _gateway 255.255.255.0 UG 50 0 0 tun0
192.168.2.0 0.0.0.0 255.255.255.0 U 100 0 0 enp3s0
firewall.test.l 0.0.0.0 255.255.255.255 UH 100 0 0 enp3s0

Allerdings wird keine Route vom OpenVPN um dies zu tun gepusht, warum der Network Manager das nun macht bleibt offen. Das so kein Internet funktioniert liegt zudem daran, das die Firewall der Gegenseite nur RDP-Verbindungen durchlässt. Weitere Abhilfe neben dem oben genannten manuellem Anlegen der VPN-Verbindung schafft das händische Konfigurieren der Route zum OpenVPN-Transfer-Netzwerk:

Anschließend sehen die Routen wie folgt aus:

Ziel Router Genmask Flags Metric Ref Use Iface
default firewall.test.l 0.0.0.0 UG 100 0 0 enp3s0
10.0.8.0 0.0.0.0 255.255.255.0 U 50 0 0 tun0
10.0.8.0 0.0.0.0 255.255.255.0 U 50 0 0 tun0
192.168.0.0 10.0.8.1 255.255.255.0 UG 50 0 0 tun0
192.168.2.0 0.0.0.0 255.255.255.0 U 100 0 0 enp3s0
firewall.test.l 0.0.0.0 255.255.255.255 UH 100 0 0 enp3s0

So funktioniert nun sowohl die OpenVPN-Verbindung als auch der Internetzugriff.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.