Veeam Agent for Microsoft Windows: Datensicherung kann nicht geöffnet werden

Bei einem Kunden wird für die Datensicherung eines PCs Veeam Agent for Microsoft Windows FREE verwendet. Vor gerade einmal vier Wochen war diese Datensicherung bereits sehr hilfreich, da eine defekte Festplatte den Computer lahm legte. Beim jüngstens Service-Fall vor ein paar Tagen allerdings konnte diese nicht verwendet werden.

Aus der Datensicherung sollten ein paar Dateien wiederhergestellt werden. Allerdings konnten die letzten x Sicherungen weder am betroffenen PC noch an einem anderen PC geöffnet werden. Es erschien immer folgende Fehlermeldung:

"Die Eingabezeichenfolge hat das falsche Format"

Auf Duetsch findet man leider in Bezug zu Veeam leider nichts dazu. Anders sieht es aus, wenn man die englischen Fehlermeldung verwendet:

"The input string is in the wrong format"

bzw.

"Input string was not in a correct format"

Der ersten Treffer bezieht sich auf ein NAS als Ziel:

Veeam Community Forums – Input string was not in correct format

Veeam Community Forums – Error on file restore [Case 03627933]

In der Tat ist es beim Kunden so, das dieser PC auf einem Windows Server 2019 sichert. Allerdings testeten wir auch den Restore von einer USB-Festplatte aus, ebenfalls mit der genannten Fehlermeldung.

Nebenbei bemerkt: Eine gleichlautende Fehlermeldungen kann einem bei verschiedenen Vorgängen angezeigt werden. Bspwl. auch beim Verbindungsversuch in VMware-Umgebungen.

Lösen konnten wir das nicht. Zum Glück gab es noch eine ca. drei Wochen alte Drive Snapshot-Sicherung, die sich wiederum ohne Probleme öffnen lies und so die notwendigen Dateien wiederhergestellt werden konnten.

Da es schnell gehen musste, konnte der Fehler zunächst nicht weiter „erforscht“ werden. Nun ein paar Tage später schaute ich mir das Ganze nochmals an.

Hilfreich (zumindest für den Support) können die Logs unter

C:\ProgramData\Veeam\Endpoint

sein. So werden Protokolle während des Versuchs die Datensicherung zu Öffnen erzeugt. Eines davon ist folgendes:

C:\ProgramData\Veeam\Endpoint\FLR__<Computername>_\VeeamAgent.MountVm.Server.log

Dort fanden sich beispeilsweise folgende Zeilen:

[08.05.2020 12:09:41] < 8036> stg| Opening storage [J:\Backup\Veeam\Backup2020-05-04T120510.vbk] in read-only mode. Failed.
[08.05.2020 12:09:41] < 8036> stg| Closing storage file [HostFS://J:\Backup\Veeam\Backup2020-05-04T120510.vbk].
[08.05.2020 12:09:41] < 8036> cli| ERR |Failed to process method {Stg.OpenRead}
[08.05.2020 12:09:41] < 8036> cli| >> |Storage version [12] is not supported for read-only access.
[08.05.2020 12:09:41] < 8036> cli| >> |--tr:Failed to open storage for read access. Storage: [J:\Backup\Veeam\Backup2020-05-04T120510.vbk].
[08.05.2020 12:09:41] < 8036> cli| >> |--tr:Failed to open storage [HostFS://J:\Backup\Veeam\Backup2020-05-04T120510.vbk[]] for read access.
[08.05.2020 12:09:41] < 8036> cli| >> |An exception was thrown from thread [8036].
[08.05.2020 12:09:41] < 8036> cli| ERR |Failed to process {Invoke} command
[08.05.2020 12:09:41] < 8036> cli| >> |Details:
[08.05.2020 12:09:41] < 8036> cli| >> |Storage version [12] is not supported for read-only access.
[08.05.2020 12:09:41] < 8036> cli| >> |--tr:Failed to open storage for read access. Storage: [J:\Backup\Veeam\Backup2020-05-04T120510.vbk].
[08.05.2020 12:09:41] < 8036> cli| >> |--tr:Failed to open storage [HostFS://J:\Backup\Veeam\Backup2020-05-04T120510.vbk[]] for read access.
[08.05.2020 12:09:41] < 8036> cli| >> |Agent failed to process method {Stg.OpenRead}.

Zur Info: Das Laufwerk „J:“ ist eine USB-Festplatte. Vor allem die Meldung:

Storage version [12] is not supported for read-only access.

wirft dabei Fragen auf. Zunächst war die Vermutung naheliegend, das es ein Rechteproblem sein könnte. Allerdings ist auf dem Ordner sowie die Dateien Vollzugriff vorhanden.

Parallel zu dem ersten Protokoll wird ein zweites unter

C:\ProgramData\Veeam\Endpoint\FLRSessions\Windows\FLR__<Computername>_\VeeamAgent.MountVm.Client.log

erstellt. Darin fanden sich allerdings keinerlei Fehler oder Warnungen.

Ob ein Bare-Metal-Recovery möglich ist wurde nicht getestet. Die beteiligten Laufwerke sowie die Datensicherung sind nicht verschlüsselt, also kann es nicht daran liegen.

Die Angelegenheit bleibt also bis hierhin ungelöst und unverstanden. Schlimmer noch: Was nutzt eine Datensicherung, wenn man sie weder Öffnen oder Wiederherstellen kann?! Seltsam ist, das es zumindest wenige Wochen zuvor noch geklappt hat.

Update 12.05.2020

Wir haben gerade einen anderen PC mit Veeam Agent for Windows in der Werkstatt. Testweise wurde eine Datensicherung an unserem Werkstatt-PC geöffnet, das klappte soweit ohne irgendwelche Überraschungen.

Das nährt den Verdacht, das bei dem erstgenannten PC mit den vermeintlich erfolgreich erstellten Datensicherungen womöglich etwas nicht stimmt.

8 Kommentare

  • Ich würde es mal mit restore von \servermyshare…. probieren

  • Funktioniert ebenfalls nicht.

  • Karl-Heinz Hess

    Hallo Andy.
    Ich habe das selbe Problem. Bei mi befinden sich aber alle Dateien (Sytem und Datensicherung) auf dem lokalen PC. Das Problem habe ich seit dem Update auf 4.0. Gott sei Dank habe ich keinen Noptfall, sondern ich teste die Datensicherungen ab und an, um sicher zu sein, dass sie auch funktionieren wenn ich sie benötige. Zudem sichere ich mein System mit mehreren Backup-Programmen. VeeAM ist also nicht lebensnotwendig für mich. Ich kann dir auch leider keine Lösung anbieten, außer dein System nicht nur mit einem Programm zu sichern. Ich habe veeAM komplett deinstalliert, und dann noch den SQL-Server mit allen Zusatzprogrammen. Danach habe ich den aktuellsten freien SQL-Server (2019) neu aufgesetzt, und veeAM neu installiert. Mit dem Ergebnis des gleichen Problems. Ich habe eine Rücksicherung von der Notfall-Disk gestartet, und bin damit weiter gekommen. Ich habe die Rücksicherung dann aber abgebrochen, um nicht mein System aus Jux und Tollerei zu schrotten. Als Zweit- und Dritt-Systemsicherung nutze ich übrigens die Freeware Macrium Reflect 7.2 (Note 1.0), und eine Kaufsftware von EaseUS ToDo Backup Home 12.0 (Note 3), die aber nicht sauber zurück sichert, und mir jedes Mal eine zusätzliche Partition (UEFI) erstellt, die dann mühsam wieder entfernt werden muss. Macrium Reflect 7.2 läuft problemlos, ist sehr schnell, und absolut kostenlos. Ich habe dir zwar jetzt nicht geholfen dein Problem zu lösen, für das nächste Mal aber einen anderen Weg aufgezeigt. Ich kann absolut nicht verstehen, warum sich veeAM den SQL-Server ans Bein bindet um sich zusätzliche Probleme einzuhandeln. Im Moment läuft veeAM noch bis zum nächsten Update mit, ist aber nur noch zweite Wahl, und wird bei Misserfolg von 4.x mitsamt dem SQL-Server deinstalliert.
    Gruß Karl-Heinz.

  • Hallo Karl-Heinz,

    schonmal gut zu Wissen das man niucht alleine ist. Ein Kölner Kollege hat ebefalls von diesem Problem berichtet.

  • Björn Wählen

    Hallo Andy,
    ich bin heute auch über die selben Fehler gestolpert. Vor ein paar Wochen lief die Wiederherstellung noch problemlos, heute nicht mehr.
    Im Internet habe ich keine Lösung gefunden, nur hier Leidensgenossen.
    Ich habe diversen kram, wie prüfen der Berechtigungen, neustart der NAS (wo die Backups liegen), austausch des Zielrechners für die Wiederherstellung, ausprobiert. Letztlich habe ich mittels Veeam Backup & Recovery ein neues Recovery-Image erstellt. Dabei fiel mir auf: Backups wurden mit dem Agent der Version 4 erstellt, das vorhandene (alte) Recovery-Image basiert auf Version 3. Wir haben also nach der letzten erfolgreichen Wiederherstellung den Agent aktualisiert und vergessen, das Recovery-Image zu erneuern.
    Test-Rechner mit Recovery-Image Agent Version 4 gestartet, Zugriff auf Backup mit Agent Version 4: Keine Fehlermeldung, Wiederherstellung erfolgreich.
    Für mich heißt das: Nach einem Agent-Update auch des Recovery-Image erneuern.
    Gruß
    Björn

  • Karl-Heinz Hess

    Natürlich habe ich ein neues Recovery-Image erstellt. Dieses Image hat den beschriebenen Fehler erzeugt. Am Wochenende war wieder einmal ein Restore fällig, bei dieser Gelegenheit habe ich veeAM 4.0 noch einmal getestet. Was soll ich sagen, der Restore lief fehlerfrei durch.
    Für alle Notfälle habe ich parallel Macrium Reflect Free installiert. Dieses Tool soll laut Anwenderberichten absolut zuverlässig arbeiten. Einen Restore habe ich damit bereits getestet, dieser lief sehr schnell, und absolut problemlos durch.
    Gruß Karl-Heinz.

  • Hallo,

    ich hatte dieses Problem heute auch und folgendermaßen gelöst:
    Nach Auswertung der Logs unter C:\ProgramData\Veeam\Endpoint\FLR___\VeeamAgent.MountVm.Server.log ist es mir aufgefallen, dass Veeam Backup auf eine alte Datensicherung zugreifen wollte, auch wenn ich sie gar nicht angesprochen/gebraucht habe.
    Warum: weiß ich nicht. Aber nach Zurückspielen dieser Datei (sie war auf externe Festplatte gesichert) ging alles wieder.
    Die Fehlermeldung ist ausgesprochen irreführend. Bei mir war gar kein Problem mit dem Zeichenformat, sondern ganz banale fehlende Datei.

  • Hallo zusammen,
    ich hatte dasselbe Problem. Ich hatte auch ein Restore DVD Image Version 4 erstellt, allerdings noch vor WIN 10 2004.
    Nun habe ich noch einmal eine DVD mit den Installationsdateien von WIN 10 2004 erstellt und siehe da – keine Fehlermeldungen mehr!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.