Windows: Drive Snapshot und eine vermeintlich intakte Festplatte

Ein Kunde brachte seinen betagten Server zu uns, da dieser nicht mehr bootete. Neben einer eindeutigen Meldung vom RAID-Controller, das eine Festplatte an einem bestimmten Port ausgewechselt werden sollte kamen bei näherer Betrachtung weitere Punkte hinzu.

Der Server ist mit vier Festplatte zu je zwei RAID-1 bestückt. Der Kunde merkte zudem an, das er monatlich “chkdsk <LW:> /R laufen lässt, ohne das es bislang zu Fehlern gekommen sei.

Alle Platten wurden ausgebaut und an einem Werkstatt-Computer zunächst mittels CrystalDiskInfo überprüft. Dabei zeigten drei von vier Festplatten bereits S.M.A.R.T.-Warnungen an. Die vierte Festplatte sei angeblich in Ordnung. Interessanterweise, neben dem Umstand das der RAID-Controller die bereits eindeutig fehlerhaften Festplatten nicht monierte, war das ausgerechnet die vierte angeblich intakte Festplatte diejenige ist die beim Booten seitens des RAID-Controllers mit Port-Fehler “angemeckert” wurde.

Jedenfalls wurde von allen Festplatten mit Drive Snapshot eine Sicherung erstellt. Bei den Dreien mit den S.M.A.R.T.-Warnungen lief das ohne weiteres durch, es wurden keine fehlerhaften Sektoren im belegtem Speicherbereich erkannt. Bei der Vierten angeblich intakten Festplatte klappte die Sicherung zwar ebenfalls, allerdings fand sich im Protokoll folgendes:

20:02:20 2 sectors need more than 200ms to read
20:02:20 8 sectors need more than 100ms to read

So ganz in Ordnung ist also doch nicht. Lange Rede, kurzer Sinn: Alle Festplatten wurden ausgetauscht, die RAIDs neu aufgebaut und die Daten wiederhergestellt.

Schön zu sehen, einmal mehr, das Drive Snapshot auch in solchen Situationen nützliche Informationen liefert und einen dabei unterstützt herauszufinden was ggf. mit einer Festplatte los ist.

2 Kommentare

  • Pingback: The good & the bad with S.M.A.R.T. – Andy's Blog

  • Das einige Sektoren mehr als 100 / 200 ms zum Lesen brauchten habe ich bei mir ebenfalls regelmäßig im Log meiner täglichen Sicherung. Mal mehrere Einträge, an anderen Tagen auch mal gar keine.
    Diese Meldungen hatte ich allerdings von Anfang an auf meinem damals *neuen* Server, der zwei HDD’s als Raid1 betreibt. Fand ich schon immer beunruhigend, aber seit 2 Jahren läuft das System bisher ohne Probleme. %-)

    Vielleicht gibt es ja noch eine andere Erklärung für diese Meldungen von Drive Snapshot als sich ankündigende Hardware-Defekte…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.