Proxmox VE 2.x: Problem mit Windows 7 x64 und SATA

Mir ist nun schon auf zwei unterschiedlichen PVE-Hosts folgendes begegnet:

Es wird eine neue virtuelle Maschine mit Windows 7 Professional x64 inkl. SP1 mit SATA als Festplattenschnittstelle installiert. Nach erfolgreicher Installation wurden Microsoft Updates installiert. Nach dem Neustart bootet Windows nicht mehr bzw. bootet direkt in die Systemstartreparatur.

KVM/Proxmox VE 2.x - Windows 7 x64 - SystemstartreparaturLeider „zerlegt“ es das Windows dermaßen, das bislang auch kein Reparaturversuch gelang. Da half auch keine Rettungs-CD oder bcdedit.

KVM/Proxmox VE 2.x - Windows 7 x64 - Systemstartreparatur-Fehler

Folgende zwei Lösungswege wurden als Workaround versucht:

Workaround 1

  • Die virtuellen Maschine beenden.
  • Die Festplattenschnittstelle von SATA auf IDE ändern.
  • Die virtuelle Maschine starten.
  • Warten bis Windows gestartet ist und die neue Hardware erkannt hat. Anschließend Windows neustarten.
  • Windows herunterfahren.
  • Die Festplattenschnittstelle von IDE auf SATA ändern.
  • Die virtuelle Maschine wieder starten.

Workaround 2

  • Windows 7 zunächst mit IDE-Schnittstelle installieren.
  • Nach den ersten Microsoft Updates auf SATA umstellen.

Allerdings begegnet einem dann zunächst der BSOD 0x0000007B, so das man zunächst MergeIDE inkl. AHCI (siehe dazu hier) ausführen muss.

Ob es sich dabei nun um ein KVM- oder Microsoft-Problem handelt, konnte bislang nicht eindeutig geklärt werden. Leider sind diese Lösungen nicht sonderlich zuverlässig. Es kam bei Tests durchaus vor, das nach einem weiteren Neustart oder einer weiteren Runde Microsoft Updates das Problem wieder auftrat.

Mit Windows Server 2008 R2 trat dieses Problem bislang nicht auf.

2 Gedanken zu „Proxmox VE 2.x: Problem mit Windows 7 x64 und SATA

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.